<!DOCTYPE html><html lang="en"><head><meta charset="utf-8"/>
<script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>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</script><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>__ez.pel=(function(){var pixels=[],pxURL="/porpoiseant/army.gif";function AddAndFirePixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0);Fire();}
function AddAndFireOrigPixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0,true);Fire();}
function GetCurrentPixels(){return pixels;}
function AddPixel(adSlot,pixelData,revenue,est_revenue,bid_floor_filled,bid_floor_prev,stat_source_id,isOrig){if(!__ez.dot.isDefined(adSlot)||__ez.dot.isAnyDefined(adSlot.getSlotElementId,adSlot.ElementId)==false){return;}
if(typeof isOrig==='undefined'){isOrig=false;}
var ad_position_id=parseInt(__ez.dot.getTargeting(adSlot,'ap'));var impId=__ez.dot.getSlotIID(adSlot),adUnit=__ez.dot.getAdUnit(adSlot,isOrig);var compId=parseInt(__ez.dot.getTargeting(adSlot,"compid"));var lineItemId=0;var creativeId=0;var ezimData=getEzimData(adSlot);if(typeof ezimData=='object'){if(ezimData.creative_id!==undefined){creativeId=ezimData.creative_id;}
if(ezimData.line_item_id!==undefined){lineItemId=ezimData.line_item_id;}}
if(__ez.dot.isDefined(impId,adUnit)&&__ez.dot.isValid(pixelData)){if((impId!=="0"||isOrig===true)&&adUnit!==""){pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),revenue:revenue,est_revenue:est_revenue,ad_position:ad_position_id,ad_size:"",bid_floor_filled:bid_floor_filled,bid_floor_prev:bid_floor_prev,stat_source_id:stat_source_id,country_code:__ez.dot.getCC(),pageview_id:__ez.dot.getPageviewId(),comp_id:compId,line_item_id:lineItemId,creative_id:creativeId,data:__ez.dot.dataToStr(pixelData),is_orig:isOrig||__ez.template.isOrig,});}}}
function AddPixelById(impFullId,pixelData,isOrig,revenue){var vals=impFullId.split('/');if(__ez.dot.isDefined(impFullId)&&vals.length===3&&__ez.dot.isValid(pixelData)){var adUnit=vals[0],impId=vals[2];var pix={type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),pageview_id:__ez.dot.getPageviewId(),data:__ez.dot.dataToStr(pixelData),is_orig:isOrig||__ez.template.isOrig};if(typeof revenue!=='undefined'){pix.revenue=revenue;}
pixels.push(pix);}}
function Fire(){if(typeof document.visibilityState!=='undefined'&&document.visibilityState==="prerender")return;if(__ez.dot.isDefined(pixels)&&pixels.length>0){var allPixels=[pixels.filter(function(pixel){return pixel.is_orig}),pixels.filter(function(pixel){return!pixel.is_orig})];allPixels.forEach(function(pixels){while(pixels.length>0){var isOrig=pixels[0].is_orig||false;var j=5;if(j>pixels.length){j=pixels.length;}
var pushPixels=pixels.splice(0,j);var pixelURL=__ez.dot.getURL(pxURL)+"?orig="+(isOrig===true?1:0)+"&sts="+btoa(JSON.stringify(pushPixels));if(typeof window.isAmp!=='undefined'&&isAmp&&typeof window._ezaq!=='undefined'&&_ezaq.hasOwnProperty("domain_id")){pixelURL+="&visit_uuid="+_ezaq['visit_uuid'];}
__ez.dot.Fire(pixelURL);}});}
pixels=[];}
function getEzimData(adSlot){if(typeof _ezim_d=="undefined"){return false;}
var adUnitName=__ez.dot.getAdUnitPath(adSlot).split('/').pop();if(typeof _ezim_d==='object'&&_ezim_d.hasOwnProperty(adUnitName)){return _ezim_d[adUnitName];}
for(var ezimKey in _ezim_d){if(ezimKey.split('/').pop()===adUnitName){return _ezim_d[ezimKey];}}
return false;}
return{Add:AddPixel,AddAndFire:AddAndFirePixel,AddAndFireOrig:AddAndFireOrigPixel,AddById:AddPixelById,Fire:Fire,GetPixels:GetCurrentPixels,};})();__ez.queue.addFile('/detroitchicago/raleigh.js', '/detroitchicago/raleigh.js?gcb=195-0&cb=5', false, [], true, false, true, false);__ez.queue.addFile('/detroitchicago/tampa.js', '/detroitchicago/tampa.js?gcb=195-0&cb=4', false, [], true, false, true, false);</script>
<script data-ezscrex="false" data-cfasync="false">(function(){if("function"===typeof window.CustomEvent)return!1;window.CustomEvent=function(c,a){a=a||{bubbles:!1,cancelable:!1,detail:null};var b=document.createEvent("CustomEvent");b.initCustomEvent(c,a.bubbles,a.cancelable,a.detail);return b}})();</script><script data-ezscrex="false" data-cfasync="false">__ez.queue.addFile('/detroitchicago/tulsa.js', '/detroitchicago/tulsa.js?gcb=195-0&cb=5', false, [], true, false, true, false);</script><meta http-equiv="x-ua-compatible" content="ie=edge"/><meta name="viewport" content="width=device-width, initial-scale=1, shrink-to-fit=no"/><style id="typography.js">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</style><style data-href="/styles.c05a3e2bc83d83bfaa21.css" data-identity="gatsby-global-css">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</style><meta name="generator" content="Gatsby 3.8.1"/><style type="text/css">
    .anchor.before {
      position: absolute;
      top: 0;
      left: 0;
      transform: translateX(-100%);
      padding-right: 4px;
    }
    .anchor.after {
      display: inline-block;
      padding-left: 4px;
    }
    h1 .anchor svg,
    h2 .anchor svg,
    h3 .anchor svg,
    h4 .anchor svg,
    h5 .anchor svg,
    h6 .anchor svg {
      visibility: hidden;
    }
    h1:hover .anchor svg,
    h2:hover .anchor svg,
    h3:hover .anchor svg,
    h4:hover .anchor svg,
    h5:hover .anchor svg,
    h6:hover .anchor svg,
    h1 .anchor:focus svg,
    h2 .anchor:focus svg,
    h3 .anchor:focus svg,
    h4 .anchor:focus svg,
    h5 .anchor:focus svg,
    h6 .anchor:focus svg {
      visibility: visible;
    }
  </style><script>
    document.addEventListener("DOMContentLoaded", function(event) {
      var hash = window.decodeURI(location.hash.replace('#', ''))
      if (hash !== '') {
        var element = document.getElementById(hash)
        if (element) {
          var scrollTop = window.pageYOffset || document.documentElement.scrollTop || document.body.scrollTop
          var clientTop = document.documentElement.clientTop || document.body.clientTop || 0
          var offset = element.getBoundingClientRect().top + scrollTop - clientTop
          // Wait for the browser to finish rendering before scrolling.
          setTimeout((function() {
            window.scrollTo(0, offset - 0)
          }), 0)
        }
      }
    })
  </script><link rel="sitemap" type="application/xml" href="/sitemap.xml"/><title data-react-helmet="true">How to Encode and Decode Base64 Data from the Command Line (With Examples)</title><link data-react-helmet="true" rel="canonical" href="https://www.sohamkamani.com/unix/base64-encode-decode/"/><link data-react-helmet="true" rel="icon" type="image/png" sizes="16x16" href="/icons/favicon-16x16.png"/><link data-react-helmet="true" rel="icon" type="image/png" sizes="32x32" href="/icons/favicon-32x32.png"/><link data-react-helmet="true" rel="shortcut icon" href="/icons/favicon.ico"/><meta data-react-helmet="true" name="image" content="https://www.sohamkamani.com/static/47d01697160c2703bb1982cf76e7bcdf/banner.drawio.png"/><meta data-react-helmet="true" name="description" content="A tutorial on encoding and decoding data into Base64 using Unix command line tools"/><meta data-react-helmet="true" name="keywords" content=""/><meta data-react-helmet="true" property="og:url" content="https://www.sohamkamani.com/unix/base64-encode-decode/"/><meta data-react-helmet="true" property="og:type" content="article"/><meta data-react-helmet="true" property="og:title" content="How to Encode and Decode Base64 Data from the Command Line (With Examples)"/><meta data-react-helmet="true" property="og:description" content="A tutorial on encoding and decoding data into Base64 using Unix command line tools"/><meta data-react-helmet="true" property="og:image" content="https://www.sohamkamani.com/static/47d01697160c2703bb1982cf76e7bcdf/banner.drawio.png"/><meta data-react-helmet="true" name="twitter:card" content="summary_large_image"/><meta data-react-helmet="true" name="twitter:creator" content="sohamkamani"/><meta data-react-helmet="true" name="twitter:title" content="How to Encode and Decode Base64 Data from the Command Line (With Examples)"/><meta data-react-helmet="true" name="twitter:description" content="A tutorial on encoding and decoding data into Base64 using Unix command line tools"/><meta data-react-helmet="true" name="twitter:image" content="https://www.sohamkamani.com/static/47d01697160c2703bb1982cf76e7bcdf/banner.drawio.png"/><meta data-react-helmet="true" name="author" content="Soham Kamani"/><script async="" src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-5676825909217296" crossorigin="anonymous"></script><link as="script" rel="preload" href="/webpack-runtime-8b5ef2ae9e4866e93e89.js"/><link as="script" rel="preload" href="/framework-97683cc387ef4ea0f734.js"/><link as="script" rel="preload" href="/app-a32b64b72c17e1f0f35b.js"/><link as="script" rel="preload" href="/07b5bdf1836fdedd29a630513ea0340a24527b15-ada249803021886eb69f.js"/><link as="script" rel="preload" href="/ca7020ea364e016c15029e3d7f472d0a8b21a712-dee1207e66fc330b2b6a.js"/><link as="script" rel="preload" href="/component---src-templates-blog-post-js-ba161302eddf5aedb4d9.js"/><link as="fetch" rel="preload" href="/page-data/unix/base64-encode-decode/page-data.json" crossorigin="anonymous"/><link as="fetch" rel="preload" href="/page-data/app-data.json" crossorigin="anonymous"/><script type="text/javascript">var ezouid = "1";</script><base href="https://www.sohamkamani.com/unix/base64-encode-decode/"><script type='text/javascript'>
var ezoTemplate = 'old_site_noads';
if(typeof ezouid == 'undefined')
{
    var ezouid = 'none';
}
var ezoFormfactor = '1';
var ezo_elements_to_check = Array();
</script><!-- START EZHEAD -->
<script data-ezscrex="false" type='text/javascript'>
var soc_app_id = '0';
var did = 334648;
var ezdomain = 'sohamkamani.com';
var ezoicSearchable = 1;
</script>
<!--{jquery}-->
<!-- END EZHEAD -->
<script data-ezscrex="false" type="text/javascript" data-cfasync="false">var _ezaq = {"ad_cache_level":0,"ad_lazyload_version":0,"ad_load_version":0,"city":"Ashburn","country":"US","days_since_last_visit":-1,"domain_id":334648,"engaged_time_visit":0,"ezcache_level":1,"ezcache_skip_code":7,"form_factor_id":1,"framework_id":1,"is_return_visitor":false,"is_sitespeed":0,"last_page_load":"","last_pageview_id":"","lt_cache_level":0,"metro_code":511,"page_ad_positions":"","page_view_count":0,"page_view_id":"1ea771f4-e609-4e68-586f-0aaa5b177bdd","position_selection_id":0,"postal_code":"20149","pv_event_count":0,"response_size_orig":193441,"response_time_orig":52,"serverid":"3.239.116.144:21235","state":"VA","t_epoch":1647970314,"template_id":120,"time_on_site_visit":0,"url":"https://www.sohamkamani.com/unix/base64-encode-decode/","user_id":0,"word_count":439,"worst_bad_word_level":0};var _ezExtraQueries = "&ez_orig=1";</script>
<script data-ezscrex='false' data-pagespeed-no-defer data-cfasync='false'>
function create_ezolpl(pvID, rv) {
    var d = new Date();
    d.setTime(d.getTime() + (365*24*60*60*1000));
    var expires = "expires="+d.toUTCString();
    __ez.ck.setByCat("ezux_lpl_334648=" + new Date().getTime() + "|" + pvID + "|" + rv + "; " + expires, 3);
}
function attach_ezolpl(pvID, rv) {
    if (document.readyState === "complete") {
        create_ezolpl(pvID, rv);
    }
    if(window.attachEvent) {
        window.attachEvent("onload", create_ezolpl, pvID, rv);
    } else {
        if(window.onload) {
            var curronload = window.onload;
            var newonload = function(evt) {
                curronload(evt);
                create_ezolpl(pvID, rv);
            };
            window.onload = newonload;
        } else {
            window.onload = create_ezolpl.bind(null, pvID, rv);
        }
    }
}

__ez.queue.addFunc("attach_ezolpl", "attach_ezolpl", ["1ea771f4-e609-4e68-586f-0aaa5b177bdd", "false"], false, ['/detroitchicago/boise.js'], true, false, false, false);
</script></head><body><div id="___gatsby"><div style="outline:none" tabindex="-1" id="gatsby-focus-wrapper"><div class="blog-post-container"><header class="header"><h1 class="header__title">{ Soham Kamani }</h1><h2 class="sub-header"><a href="/about">About</a> •<!-- --> <a href="/blog">Blog</a> •<!-- --> <a href="https://github.com/sohamkamani">Github</a> •<!-- --> <a href="https://twitter.com/sohamkamani">Twitter</a></h2><div class="toggle-dark-mode"><div class="react-toggle"><div class="react-toggle-track"><div class="react-toggle-track-check"><div style="font-size:15px;position:relative;top:5px">🌙</div></div><div class="react-toggle-track-x"><div style="font-size:15px;position:relative;top:5px">☀️</div></div></div><div class="react-toggle-thumb"></div><input type="checkbox" id="toggle-dark-mode" class="react-toggle-screenreader-only"/></div></div><div id="out-of-view"></div></header><div class="blog-post"><article><header><h1 class="blog-post__header">How to Encode and Decode Base64 Data from the Command Line (With Examples)</h1><span class="timestamp"><time datetime="2022-03-19T08:47:37.538Z">March 19, 2022</time></span></header><p>In this post we wil learn how to encode and decode from the <a href="https://en.wikipedia.org/wiki/Base64">base64 format</a> using the <a href="https://linux.die.net/man/1/base64">base64</a> command line tool, typically pre-installed on most Unix base operating systems, like MacOS or Linux.</p><p><span class="gatsby-resp-image-wrapper" style="position:relative;display:block;margin-left:auto;margin-right:auto;max-width:800px">
      <a class="gatsby-resp-image-link" href="/static/47d01697160c2703bb1982cf76e7bcdf/6acbf/banner.drawio.png" style="display:block" target="_blank" rel="noopener">
    <span class="gatsby-resp-image-background-image" style="padding-bottom:50%;position:relative;bottom:0;left:0;background-image:url(&#39;data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABQAAAAKCAYAAAC0VX7mAAAACXBIWXMAAAsTAAALEwEAmpwYAAACaElEQVQoz22MWU8TURiG55f4B/SOuMWowQvDzzDx0niD0RCXIBGqISAYLVg2RWtIKRS7Idh9odNpZzpAWcrMtNOBblBEQKqMy3lNjxC98OLJ837v+b7DlMpbuqzk9Gwur2fWZF3bKNJMO1XTM5Kir8kK7XKqpq9kJF1SctT13fx6gb5Jclbf/rSrM3K+goS4CpZfQiQugkut0JlflKhTSwr1wqpKqc+hmIDgHI9UWqJ3UW4ecWEZ9b8YrXpICjs/SfHzL0ph5we1tnVIAmya+GMLJMAuEt/cPImJEgknlun+9jeQzQOQrRpItQZS2QfRqjph5nMHOEbMHucaxOwX+JN5BHiN2pdQERQ2EBQ0sEtlOH08HN4k7N4kbDMx+DkJaa0GhpNKSMhlSjK7Sc3VZ6UCQa3+JVcFn61gofAVY24OTU1XcfHSBTReacTZc6fR8rATvPodjCfxAc7wFGzecWpXxA5X5D3sgUlM+SdoZw/aMBt3wxm2IV1cgZNdh2k8jAFrBD0jDtw3GGGyBOFZ3AczLSqYFrNwiwrcqT/ZJcg0O5NrcCQz1C5BgrOeBRUTsSqmuF3MLBMY+m1ovHweLR19sAs1MI8sb9Ey3I9W8wjaxkbx4M0QWt+9wr3XAzCGPmKQC8HEBo4IwsR6MRzlMDRbgDmyh9tPRnGm4SRu3O2GOboP5tl0HN2OKLrsUXTaQnjqiqH3qHvuEdDnE2H8hz5/Ci9mV9FrX8dL7x5utg2i4dQJXG/uQL9nF8xjaxEGaxmGiSOsJXRYS7RrtxTRbin8hw20W/Iw2Eq4Ywzj2q0uNPfMwDBZwm+QRInFHsoSTwAAAABJRU5ErkJggg==&#39;);background-size:cover;display:block"></span>
  <picture>
          <source srcset="/static/47d01697160c2703bb1982cf76e7bcdf/ba381/banner.drawio.webp 200w,/static/47d01697160c2703bb1982cf76e7bcdf/7f61c/banner.drawio.webp 400w,/static/47d01697160c2703bb1982cf76e7bcdf/d00b9/banner.drawio.webp 800w,/static/47d01697160c2703bb1982cf76e7bcdf/4ad2e/banner.drawio.webp 1001w" sizes="(max-width: 800px) 100vw, 800px" type="image/webp"/>
          <source srcset="/static/47d01697160c2703bb1982cf76e7bcdf/772e8/banner.drawio.png 200w,/static/47d01697160c2703bb1982cf76e7bcdf/e17e5/banner.drawio.png 400w,/static/47d01697160c2703bb1982cf76e7bcdf/5a190/banner.drawio.png 800w,/static/47d01697160c2703bb1982cf76e7bcdf/6acbf/banner.drawio.png 1001w" sizes="(max-width: 800px) 100vw, 800px" type="image/png"/>
          <img class="gatsby-resp-image-image" src="/static/47d01697160c2703bb1982cf76e7bcdf/5a190/banner.drawio.png" alt="banner" title="banner" loading="lazy" decoding="async" style="width:100%;height:100%;margin:0;vertical-align:middle;position:absolute;top:0;left:0"/>
        </picture>
  </a>
    </span></p><h2 id="installation" style="position:relative"><a href="#installation" aria-label="installation permalink" class="anchor before"><svg aria-hidden="true" focusable="false" height="16" version="1.1" viewBox="0 0 16 16" width="16"><path fill-rule="evenodd" d="M4 9h1v1H4c-1.5 0-3-1.69-3-3.5S2.55 3 4 3h4c1.45 0 3 1.69 3 3.5 0 1.41-.91 2.72-2 3.25V8.59c.58-.45 1-1.27 1-2.09C10 5.22 8.98 4 8 4H4c-.98 0-2 1.22-2 2.5S3 9 4 9zm9-3h-1v1h1c1 0 2 1.22 2 2.5S13.98 12 13 12H9c-.98 0-2-1.22-2-2.5 0-.83.42-1.64 1-2.09V6.25c-1.09.53-2 1.84-2 3.25C6 11.31 7.55 13 9 13h4c1.45 0 3-1.69 3-3.5S14.5 6 13 6z"></path></svg></a>Installation</h2><p>The <code class="language-text">bas64</code> command is usually pre-installed on most Unix based operating systems. You can check if you already have it installed by opening your terminal and typing:</p><div class="gatsby-highlight" data-language="bash"><pre class="language-bash"><code class="language-bash">base64 --help</code></pre></div><p>If installed, you should get some help information printed to your terminal. Otherwise, you can use your operating systems package manager (like <code class="language-text">apt</code> or <code class="language-text">brew</code>) to install it manually.</p><h2 id="encoding-to-base64" style="position:relative"><a href="#encoding-to-base64" aria-label="encoding to base64 permalink" class="anchor before"><svg aria-hidden="true" focusable="false" height="16" version="1.1" viewBox="0 0 16 16" width="16"><path fill-rule="evenodd" d="M4 9h1v1H4c-1.5 0-3-1.69-3-3.5S2.55 3 4 3h4c1.45 0 3 1.69 3 3.5 0 1.41-.91 2.72-2 3.25V8.59c.58-.45 1-1.27 1-2.09C10 5.22 8.98 4 8 4H4c-.98 0-2 1.22-2 2.5S3 9 4 9zm9-3h-1v1h1c1 0 2 1.22 2 2.5S13.98 12 13 12H9c-.98 0-2-1.22-2-2.5 0-.83.42-1.64 1-2.09V6.25c-1.09.53-2 1.84-2 3.25C6 11.31 7.55 13 9 13h4c1.45 0 3-1.69 3-3.5S14.5 6 13 6z"></path></svg></a>Encoding to Base64</h2><p>To encode plain text into its base64 format, you can execute:</p><div class="gatsby-highlight" data-language="bash"><pre class="language-bash"><code class="language-bash"><span class="token builtin class-name">echo</span> <span class="token string">&#34;sample text&#34;</span> <span class="token operator">|</span> base64</code></pre></div><p>Which will print the base64 output:</p><div class="gatsby-highlight" data-language="text"><pre class="language-text"><code class="language-text">c2FtcGxlIHRleHQK</code></pre></div><h2 id="decoding-from-base64" style="position:relative"><a href="#decoding-from-base64" aria-label="decoding from base64 permalink" class="anchor before"><svg aria-hidden="true" focusable="false" height="16" version="1.1" viewBox="0 0 16 16" width="16"><path fill-rule="evenodd" d="M4 9h1v1H4c-1.5 0-3-1.69-3-3.5S2.55 3 4 3h4c1.45 0 3 1.69 3 3.5 0 1.41-.91 2.72-2 3.25V8.59c.58-.45 1-1.27 1-2.09C10 5.22 8.98 4 8 4H4c-.98 0-2 1.22-2 2.5S3 9 4 9zm9-3h-1v1h1c1 0 2 1.22 2 2.5S13.98 12 13 12H9c-.98 0-2-1.22-2-2.5 0-.83.42-1.64 1-2.09V6.25c-1.09.53-2 1.84-2 3.25C6 11.31 7.55 13 9 13h4c1.45 0 3-1.69 3-3.5S14.5 6 13 6z"></path></svg></a>Decoding from Base64</h2><p>Let’s use the output from the above example to see how to decode it back into plain text.</p><p>We can use the <code class="language-text">-D</code> option to decode from base64:</p><div class="gatsby-highlight" data-language="bash"><pre class="language-bash"><code class="language-bash"><span class="token builtin class-name">echo</span> <span class="token string">&#34;c2FtcGxlIHRleHQK&#34;</span> <span class="token operator">|</span> base64 -D</code></pre></div><p>This will print our original string as output:</p><div class="gatsby-highlight" data-language="text"><pre class="language-text"><code class="language-text">sample text</code></pre></div><h2 id="encodingdecoding-files" style="position:relative"><a href="#encodingdecoding-files" aria-label="encodingdecoding files permalink" class="anchor before"><svg aria-hidden="true" focusable="false" height="16" version="1.1" viewBox="0 0 16 16" width="16"><path fill-rule="evenodd" d="M4 9h1v1H4c-1.5 0-3-1.69-3-3.5S2.55 3 4 3h4c1.45 0 3 1.69 3 3.5 0 1.41-.91 2.72-2 3.25V8.59c.58-.45 1-1.27 1-2.09C10 5.22 8.98 4 8 4H4c-.98 0-2 1.22-2 2.5S3 9 4 9zm9-3h-1v1h1c1 0 2 1.22 2 2.5S13.98 12 13 12H9c-.98 0-2-1.22-2-2.5 0-.83.42-1.64 1-2.09V6.25c-1.09.53-2 1.84-2 3.25C6 11.31 7.55 13 9 13h4c1.45 0 3-1.69 3-3.5S14.5 6 13 6z"></path></svg></a>Encoding/Decoding Files</h2><p>We can use the <code class="language-text">-i</code> and <code class="language-text">-o</code> options to specify input and output files, respectively.</p><p>Consider a file <code class="language-text">sample.txt</code> in our current directory. If we want to encode the contents of this file into base64, we can run the command:</p><div class="gatsby-highlight" data-language="bash"><pre class="language-bash"><code class="language-bash">base64 -i sample.txt -o sample.base64</code></pre></div><p>This will convert the contents of the <code class="language-text">sample.txt</code> file and store them into a new file <code class="language-text">sample.base64</code>.</p><p>For decoding base64 files, we can run:</p><div class="gatsby-highlight" data-language="bash"><pre class="language-bash"><code class="language-bash">base64 -D -i sample.base64 -o sample.out.html</code></pre></div><blockquote><p>Since Base64 is a binary format, and encodes/decodes directly from binary data, we can use it to convert any type of file (text, video, executable) into Base64 strings</p></blockquote></article><ul class=" sidebar__sharebar"><li class="sidebar__sharebar__label"><p>Share this on:</p></li><li><p><a target="_blank" rel="noopener" href="https://twitter.com/share?url=https://www.sohamkamani.com/unix/base64-encode-decode/&amp;text=How to Encode and Decode Base64 Data from the Command Line (With Examples)&amp;via=sohamkamani&amp;hashtags="><img alt="twitter share" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHZpZXdCb3g9IjAgMCA0NDggNTEyIj48cGF0aCBmaWxsPSJyZ2IoMjksMTYxLDI0MikiIGQ9Ik00MDAgMzJINDhDMjEuNSAzMiAwIDUzLjUgMCA4MHYzNTJjMCAyNi41IDIxLjUgNDggNDggNDhoMzUyYzI2LjUgMCA0OC0yMS41IDQ4LTQ4VjgwYzAtMjYuNS0yMS41LTQ4LTQ4LTQ4em0tNDguOSAxNTguOGMuMiAyLjguMiA1LjcuMiA4LjUgMCA4Ni43LTY2IDE4Ni42LTE4Ni42IDE4Ni42LTM3LjIgMC03MS43LTEwLjgtMTAwLjctMjkuNCA1LjMuNiAxMC40LjggMTUuOC44IDMwLjcgMCA1OC45LTEwLjQgODEuNC0yOC0yOC44LS42LTUzLTE5LjUtNjEuMy00NS41IDEwLjEgMS41IDE5LjIgMS41IDI5LjYtMS4yLTMwLTYuMS01Mi41LTMyLjUtNTIuNS02NC40di0uOGM4LjcgNC45IDE4LjkgNy45IDI5LjYgOC4zYTY1LjQ0NyA2NS40NDcgMCAwIDEtMjkuMi01NC42YzAtMTIuMiAzLjItMjMuNCA4LjktMzMuMSAzMi4zIDM5LjggODAuOCA2NS44IDEzNS4yIDY4LjYtOS4zLTQ0LjUgMjQtODAuNiA2NC04MC42IDE4LjkgMCAzNS45IDcuOSA0Ny45IDIwLjcgMTQuOC0yLjggMjktOC4zIDQxLjYtMTUuOC00LjkgMTUuMi0xNS4yIDI4LTI4LjggMzYuMSAxMy4yLTEuNCAyNi01LjEgMzcuOC0xMC4yLTguOSAxMy4xLTIwLjEgMjQuNy0zMi45IDM0eiIvPjwvc3ZnPg==" class="sidebar__icon"/></a></p></li><li><p><a target="_blank" rel="noopener" href="https://facebook.com/sharer.php?u=https://www.sohamkamani.com/unix/base64-encode-decode/"><img alt="facebook share" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHZpZXdCb3g9IjAgMCA0NDggNTEyIj48cGF0aCBmaWxsPSIjM0M1QTk5IiBkPSJNNDQ4IDgwdjM1MmMwIDI2LjUtMjEuNSA0OC00OCA0OGgtODUuM1YzMDIuOGg2MC42bDguNy02Ny42aC02OS4zVjE5MmMwLTE5LjYgNS40LTMyLjkgMzMuNS0zMi45SDM4NFY5OC43Yy02LjItLjgtMjcuNC0yLjctNTIuMi0yLjctNTEuNiAwLTg3IDMxLjUtODcgODkuNHY0OS45SDE4NHY2Ny42aDYwLjlWNDgwSDQ4Yy0yNi41IDAtNDgtMjEuNS00OC00OFY4MGMwLTI2LjUgMjEuNS00OCA0OC00OGgzNTJjMjYuNSAwIDQ4IDIxLjUgNDggNDh6Ii8+PC9zdmc+" class="sidebar__icon"/></a></p></li></ul><hr/><div class="undefined subscription-form"><form action="https://sohamkamani.us17.list-manage.com/subscribe/post?u=84ea1f74b92bc659f025f95fe&amp;amp;id=dc1498c2fe&amp;SIGNUP=%2Funix%2Fbase64-encode-decode%2F" method="post" name="mc-embedded-subscribe-form" class="validate" target="_blank" rel="noopener" novalidate=""><div><p>Like what I write? Join my mailing list, and I&#39;ll let you know whenever I write another post. No spam, I promise!</p><div class="mc-field-group"><label>Email Address:<input type="email" name="EMAIL" class="required email mail-list-email"/></label></div><div class="clear"><div class="response" style="display:none"></div><div class="response" style="display:none"></div></div><div style="position:absolute;left:-5000px" aria-hidden="true"><input type="text" name="b_84ea1f74b92bc659f025f95fe_dc1498c2fe" tabindex="-1" value=""/></div><div class="clear"><input type="submit" value="Subscribe" name="subscribe" class="button mail-list-subscribe"/></div></div></form></div><h2>Comments</h2><div id="disqus_thread"></div><section class="bio"><img src="data:image/jpeg;base64,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" alt="Soham Kamani"/><p class="bio__description">Written by <strong>Soham Kamani</strong>, an<!-- --> <a href="https://www.packtpub.com/books/info/authors/soham-kamani">author</a>,and a full-stack developer who has extensive experience in the JavaScript ecosystem, and building large scale applications in Go. He is an<!-- --> <a href="https://github.com/sohamkamani">open source enthusiast</a> and an avid blogger. You should<!-- --> <a href="https://twitter.com/sohamkamani">follow him on Twitter</a></p></section></div><nav class="blog-contents"><div><h3>In this post:</h3><ul><li style="padding-left:0px">1. <a href="#installation">Installation</a></li><li style="padding-left:0px">2. <a href="#encoding-to-base64">Encoding to Base64</a></li><li style="padding-left:0px">3. <a href="#decoding-from-base64">Decoding from Base64</a></li><li style="padding-left:0px">4. <a href="#encodingdecoding-files">Encoding/Decoding Files</a></li></ul></div><div></div></nav><aside class="sidebar"><h3 class="not-on-phones">Share this on:</h3><ul class="not-on-phones sidebar__sharebar"><li><p><a target="_blank" rel="noopener" href="https://twitter.com/share?url=https://www.sohamkamani.com/unix/base64-encode-decode/&amp;text=How to Encode and Decode Base64 Data from the Command Line (With Examples)&amp;via=sohamkamani&amp;hashtags="><img alt="twitter share" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHZpZXdCb3g9IjAgMCA0NDggNTEyIj48cGF0aCBmaWxsPSJyZ2IoMjksMTYxLDI0MikiIGQ9Ik00MDAgMzJINDhDMjEuNSAzMiAwIDUzLjUgMCA4MHYzNTJjMCAyNi41IDIxLjUgNDggNDggNDhoMzUyYzI2LjUgMCA0OC0yMS41IDQ4LTQ4VjgwYzAtMjYuNS0yMS41LTQ4LTQ4LTQ4em0tNDguOSAxNTguOGMuMiAyLjguMiA1LjcuMiA4LjUgMCA4Ni43LTY2IDE4Ni42LTE4Ni42IDE4Ni42LTM3LjIgMC03MS43LTEwLjgtMTAwLjctMjkuNCA1LjMuNiAxMC40LjggMTUuOC44IDMwLjcgMCA1OC45LTEwLjQgODEuNC0yOC0yOC44LS42LTUzLTE5LjUtNjEuMy00NS41IDEwLjEgMS41IDE5LjIgMS41IDI5LjYtMS4yLTMwLTYuMS01Mi41LTMyLjUtNTIuNS02NC40di0uOGM4LjcgNC45IDE4LjkgNy45IDI5LjYgOC4zYTY1LjQ0NyA2NS40NDcgMCAwIDEtMjkuMi01NC42YzAtMTIuMiAzLjItMjMuNCA4LjktMzMuMSAzMi4zIDM5LjggODAuOCA2NS44IDEzNS4yIDY4LjYtOS4zLTQ0LjUgMjQtODAuNiA2NC04MC42IDE4LjkgMCAzNS45IDcuOSA0Ny45IDIwLjcgMTQuOC0yLjggMjktOC4zIDQxLjYtMTUuOC00LjkgMTUuMi0xNS4yIDI4LTI4LjggMzYuMSAxMy4yLTEuNCAyNi01LjEgMzcuOC0xMC4yLTguOSAxMy4xLTIwLjEgMjQuNy0zMi45IDM0eiIvPjwvc3ZnPg==" class="sidebar__icon"/></a></p></li><li><p><a target="_blank" rel="noopener" href="https://facebook.com/sharer.php?u=https://www.sohamkamani.com/unix/base64-encode-decode/"><img alt="facebook share" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHZpZXdCb3g9IjAgMCA0NDggNTEyIj48cGF0aCBmaWxsPSIjM0M1QTk5IiBkPSJNNDQ4IDgwdjM1MmMwIDI2LjUtMjEuNSA0OC00OCA0OGgtODUuM1YzMDIuOGg2MC42bDguNy02Ny42aC02OS4zVjE5MmMwLTE5LjYgNS40LTMyLjkgMzMuNS0zMi45SDM4NFY5OC43Yy02LjItLjgtMjcuNC0yLjctNTIuMi0yLjctNTEuNiAwLTg3IDMxLjUtODcgODkuNHY0OS45SDE4NHY2Ny42aDYwLjlWNDgwSDQ4Yy0yNi41IDAtNDgtMjEuNS00OC00OFY4MGMwLTI2LjUgMjEuNS00OCA0OC00OGgzNTJjMjYuNSAwIDQ4IDIxLjUgNDggNDh6Ii8+PC9zdmc+" class="sidebar__icon"/></a></p></li></ul><h3>Social stuff:</h3><nav class="social-bar"><ul><li><a href="https://twitter.com/sohamkamani"><img alt="follow on twitter" src="data:image/svg+xml;base64,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"/> Follow me on Twitter</a></li><li><a href="https://github.com/sohamkamani"><img alt="follow on github" src="data:image/svg+xml;base64,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"/> Fork me on Github</a></li><li><a href="https://www.linkedin.com/in/soham-kamani-74034999/"><img alt="follow on linkedin" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHZpZXdCb3g9IjAgMCA0NDggNTEyIj48cGF0aCBmaWxsPSJyZ2IoMCwxMTksMTgxKSIgZD0iTTQxNiAzMkgzMS45QzE0LjMgMzIgMCA0Ni41IDAgNjQuM3YzODMuNEMwIDQ2NS41IDE0LjMgNDgwIDMxLjkgNDgwSDQxNmMxNy42IDAgMzItMTQuNSAzMi0zMi4zVjY0LjNjMC0xNy44LTE0LjQtMzIuMy0zMi0zMi4zek0xMzUuNCA0MTZINjlWMjAyLjJoNjYuNVY0MTZ6bS0zMy4yLTI0M2MtMjEuMyAwLTM4LjUtMTcuMy0zOC41LTM4LjVTODAuOSA5NiAxMDIuMiA5NmMyMS4yIDAgMzguNSAxNy4zIDM4LjUgMzguNSAwIDIxLjMtMTcuMiAzOC41LTM4LjUgMzguNXptMjgyLjEgMjQzaC02Ni40VjMxMmMwLTI0LjgtLjUtNTYuNy0zNC41LTU2LjctMzQuNiAwLTM5LjkgMjctMzkuOSA1NC45VjQxNmgtNjYuNFYyMDIuMmg2My43djI5LjJoLjljOC45LTE2LjggMzAuNi0zNC41IDYyLjktMzQuNSA2Ny4yIDAgNzkuNyA0NC4zIDc5LjcgMTAxLjlWNDE2eiIvPjwvc3ZnPg=="/> Connect on LinkedIn</a></li></ul></nav><div id="buys-my-coffee" class="undefined buys-my-coffee"></div><div class="not-on-phones subscription-form"><form action="https://sohamkamani.us17.list-manage.com/subscribe/post?u=84ea1f74b92bc659f025f95fe&amp;amp;id=dc1498c2fe&amp;SIGNUP=%2Funix%2Fbase64-encode-decode%2F" method="post" name="mc-embedded-subscribe-form" class="validate" target="_blank" rel="noopener" novalidate=""><div><p>Like what I write? Join my mailing list, and I&#39;ll let you know whenever I write another post. No spam, I promise!</p><div class="mc-field-group"><label>Email Address:<input type="email" name="EMAIL" class="required email mail-list-email"/></label></div><div class="clear"><div class="response" style="display:none"></div><div class="response" style="display:none"></div></div><div style="position:absolute;left:-5000px" aria-hidden="true"><input type="text" name="b_84ea1f74b92bc659f025f95fe_dc1498c2fe" tabindex="-1" value=""/></div><div class="clear"><input type="submit" value="Subscribe" name="subscribe" class="button mail-list-subscribe"/></div></div></form></div></aside><div id="legacy-scripts" class="undefined legacy-scripts"></div></div></div><div id="gatsby-announcer" style="position:absolute;top:0;width:1px;height:1px;padding:0;overflow:hidden;clip:rect(0, 0, 0, 0);white-space:nowrap;border:0" aria-live="assertive" aria-atomic="true"></div></div><script id="gatsby-script-loader">/*<![CDATA[*/window.pagePath="/unix/base64-encode-decode/";/*]]>*/</script><script id="gatsby-chunk-mapping">/*<![CDATA[*/window.___chunkMapping={"polyfill":["/polyfill-2019c53335ea869f9ccc.js"],"app":["/app-a32b64b72c17e1f0f35b.js"],"component---cache-caches-gatsby-plugin-offline-app-shell-js":["/component---cache-caches-gatsby-plugin-offline-app-shell-js-33b4fa5e01cace9f966d.js"],"component---src-pages-404-js":["/component---src-pages-404-js-bd55fdcac8dcd04dafde.js"],"component---src-pages-about-js":["/component---src-pages-about-js-1ee4abba37e5a88617cd.js"],"component---src-pages-blog-data-science-js":["/component---src-pages-blog-data-science-js-ae33f1c34d1c42990af5.js"],"component---src-pages-blog-golang-js":["/component---src-pages-blog-golang-js-6656eee308532a55131e.js"],"component---src-pages-blog-javascript-js":["/component---src-pages-blog-javascript-js-f067ed8a209ee4af6a6b.js"],"component---src-pages-blog-other-js":["/component---src-pages-blog-other-js-4547053e66bf86750245.js"],"component---src-pages-blog-react-js":["/component---src-pages-blog-react-js-75d1fa4ff11125b63b63.js"],"component---src-pages-index-js":["/component---src-pages-index-js-5320a2b4a2237c023e84.js"],"component---src-pages-javascript-localstorage-with-ttl-expiry-index-mdx":["/component---src-pages-javascript-localstorage-with-ttl-expiry-index-mdx-dd1083cf6a9ae1e933bf.js"],"component---src-pages-javascript-making-a-node-js-test-runner-index-mdx":["/component---src-pages-javascript-making-a-node-js-test-runner-index-mdx-87e8cd290ad56af9b7e1.js"],"component---src-pages-nodejs-file-system-guide-index-mdx":["/component---src-pages-nodejs-file-system-guide-index-mdx-c965b8eb7e0e302f3950.js"],"component---src-templates-all-posts-js":["/component---src-templates-all-posts-js-7b0fa5a28d1e27bb28ab.js"],"component---src-templates-blog-post-js":["/component---src-templates-blog-post-js-ba161302eddf5aedb4d9.js"]};/*]]>*/</script><script src="/polyfill-2019c53335ea869f9ccc.js" nomodule=""></script><script src="/component---src-templates-blog-post-js-ba161302eddf5aedb4d9.js" async=""></script><script src="/ca7020ea364e016c15029e3d7f472d0a8b21a712-dee1207e66fc330b2b6a.js" async=""></script><script src="/07b5bdf1836fdedd29a630513ea0340a24527b15-ada249803021886eb69f.js" async=""></script><script src="/app-a32b64b72c17e1f0f35b.js" async=""></script><script src="/framework-97683cc387ef4ea0f734.js" async=""></script><script src="/webpack-runtime-8b5ef2ae9e4866e93e89.js" async=""></script><script type='text/javascript' style='display:none;' async>
__ez.queue.addFile('/detroitchicago/edmonton.webp', '/detroitchicago/edmonton.webp?a=a&cb=0&shcb=34', true, ['/detroitchicago/minneapolis.js'], true, false, false, false);
__ez.queue.addFile('/porpoiseant/jellyfish.webp', '/porpoiseant/jellyfish.webp?a=a&cb=0&shcb=34', false, [], true, false, false, false);
</script>

<script>var _audins_dom="sohamkamani_com",_audins_did=334648;__ez.queue.addDelayFunc("audins.js","__ez.script.add", "//go.ezoic.net/detroitchicago/audins.js?cb=195-0");</script><noscript><div style="display:none;"><img src="//pixel.quantserve.com/pixel/p-31iz6hfFutd16.gif?labels=Domain.sohamkamani_com,DomainId.334648" border="0" height="1" width="1" alt="Quantcast"/></div></noscript>
<script type="text/javascript" data-cfasync="false"></script>
<script>__ez.queue.addFile('/tardisrocinante/vitals.js', '/tardisrocinante/vitals.js?gcb=0&cb=3', false, ['/detroitchicago/minneapolis.js'], true, false, true, false);</script></body></html>